Trouble shooting the Application Catalog

Issue Identification: http://<sccm servername>/CMApplicationCatalog is not displaying the Catalog Content

Site Roles involved: Application catalog web service point and application catalog website point

Site Status Critical: Application Catalog website point

Component Status Critical: SMS_PORTALWEB_CONTROL_MANAGER

Error Found: http://localhost/CMApplicationCatalog/default.aspx is displaying error in default website in SCCM Server

Log files: smsportalwebsetup.log

XHF96C.jpeg 


Solutions which didn’t work 

       Reference from internet:

Browse to the Windows\Microsoft.NET\Framework\v4.0.30319 folder DOS.

Run the following command:

aspnet_regiis.exe -i

HdqrzS.jpeg 

After that restarted the sccm services but still component in critical state and log shows the same error

Note: Latest one dot net version should be used for the above command ( ex: 4.0 in my case)

So reference from internet didn’t helped here

       Removing the role application catalog website point(which is critical in site status)  and readding the role also didn’t help

 

Solution did worked 

So thought of doing the manual installation with all parameters to track the error in GUI Mode

Command line used is d:\Program Files\Microsoft Configuration Manager\bin\x64\portlweb.msi

PORTALNAME="CMApplicationCatalog" SMSSSLSTATE=0 PORTALLANGPACKFLAGS=0

PORTALLANGPACKFOLDER="d:\Program Files\Microsoft Configuration Manager\bin\x64\catalog\"

PORTALPATH="d:\Program Files\SMS_CCM" PORTALLOGMAXSIZE=8000000 

Yg24tp.jpeg

vA1Krh.jpeg

0LzLcn.jpeg

After this checked the url http://localhost/CMApplicationCatalog/default.aspx in SCCM Server , I can see it loads the application catalog web page but no application were listed with permission error info.

One main thing is Patience. Log will display as installation was successful but if you look at the task manager still rolesetup.exe is still running. Once rolesetup.exe is exit from task manager we can check the url again

Bingo it starts working now

gMut9l.jpeg