/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


Advertised Shortcuts not populating files

10/08/2003 3792 views
I have created an MSI that will call a custome action to silent install an application. After it is finished, I copy some files to the My Documents folder and make a lot of changes in the Current User area. The advertised shortcut Icon is a generic Icon and not the one I had specified. When someone else logs onto the machine and then launches the icon, it does do a gathering information. The registry keys are present but the files are not placed in their My Documents folder. So I can consitantly get the reg keys entered but not the files. Does anyone have any idea on this?

John Summers
0 Comments   [ + ] Show comments

Comments


Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

All Answers

1
Hi,

Have you embeded the files into the MSI? And given them the appropriate destination path to the My Documents folder?
Answered 10/09/2003 by: BarryB
Orange Belt

1
Two other things to watch out for:

1) The repair option you describe happens at the feature level. So if you have your registry files in one feature, and the files in another, you will need to account for the files separately.

2) Take a look at the component you have your files in and make sure the one marked as "keyfile" is not something that may already be in the user's my documents folder. That one marked as keyfile for the component will be the only one that matters when it is determining if the files need to be installed or not.

Good luck!
Answered 10/14/2003 by: bkelly
Red Belt

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ