/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


Can't PXE boot after upgrading K2000 to 4.0

04/05/2017 3743 views
Yesterday I upgraded our K2000 and RSA's to version 4.0 and immediately lost the ability to PXE boot.  In our setup we are booting to our RSA's.  Each of the RSA's is set to use the onboard DHCP server.  When I attempt a legacy PXE boot the PXE screen loads and I see that my laptop is being assigned an IP and it also correctly shows the DHCP IP.  However, no matter which model of laptop I try to boot with it always end up with the error "No configuration methods succeeded (http://ipxe.org/040ee119) Selected boot device failed.  Press any key to reboot the system."  I can still USB boot to the RSA's with no trouble.

I tried applying the 4.1 update hoping that it would resolve the issue, the problem remains.  Can anyone shed some light on this?  Thanks in advance for any insight you might have.
1 Comment   [ + ] Show comment

Comments

  • I just completed the update to 4.0 and then 4.1 not an hour ago, just tested and my PXE stills works exactly the way it did pre-update. Maybe one of the update scripts broke something?(IE call support)

All Answers

0
The upgrade of the appliance to 4.0 changed the PXE process from pre-linux to iPXE, this gives the ability to update the 2008/2012 Microsoft server to use polices and determine if its  Legacy or UEFI pxe boot being requested.

If using the 2008 Microsoft DHCP server the option 67 file name can be changed to unidonly.kpxe for legacy booting, or ipxe.efi for a UEFI boot. The 2012 server has the option to create polices which can determine which type is needed from the PXE request.

Non-Microsoft DHCP servers are a little different and will need to work with the software manufacture for the specifics to implement polices if its an option. The example code below may help.

Example:
option arch code 93 = unsigned integer 16; # RFC4578
option custom-lan-0 code 244 = ip-address;
[...]
subnet 172.16.2.0 netmask 255.255.255.0 {
    pool {
        range 172.16.2.50 172.16.2.99;
    }
    option routers 172.16.2.5;
    option domain-name-servers 172.16.2.5;
    option custom-lan-0 172.16.2.174;
    next-server 172.16.2.174;
    if option arch = 00:06 {      # This entry is for PXE booting systems with 
        filename "ipxe.efi";        # 32-bit UEFI firmware, which isn't supported
    } else if option arch = 00:07 {
        filename "ipxe.efi";
    } else if option arch = 00:09 {
        filename "ipxe.efi";
    } else {
        filename "undionly.kpxe";
    }
Answered 04/05/2017 by: TheAustinDave
Brown Belt

  • This makes sense...but I'm using my RSA's onboard DHCP server. I'm assuming I wouldn't need to make these changes on that appliance...but if I'm wrong about that, where would I make those changes?
    • The testing with the RSA and appliance DHCP shows it does boot to both UEFI or Legacy mode for systems. If this works to PXE boot direct to the K2 but not the RSA I would see if there are any other DHCP services which could interfere (perhaps a bluecoat, firewall, or some other appliance).
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ