Software Deployment Question

Chrome SHOULD NOT allow to be default browser

02/20/2014 29865 views

Hello All, i have deployed google chrome to users machines. I DO NOT want used to "MAKE google chrome as default from the settings" - Please help me find a way with which i can disable this option out.

Google chrome Version 31.0



Answer Summary:
0 Comments   [ + ] Show comments


Community Chosen Answer


Have you set up any Chrome GPO's?

There is a setting within the Chrome ADM template that can be applied.

We set ours as following;

User configuration>Administrative templates>Google>Google Chrome

Set "Set Chrome as Default Browser" to disabled


Everything available from here;



Answered 02/20/2014 by: c-team@jeron.je
Senior White Belt

All Answers


Details of what the ADM template changes in the registry, if you're not using GPO configuration, can be found here:



Answered 02/20/2014 by: dunnpy
Red Belt

  • DefaultBrowserSettingEnabled

    Set Chrome as Default Browser
    Data type:
    Boolean (REG_DWORD)
    Windows registry location:
    Mac/Linux preference name:
    Supported on:
    Google Chrome (Linux, Mac, Windows) since version 11
    Supported features:
    Dynamic Policy Refresh: Yes, Per Profile: No
    Configures the default browser checks in Google Chrome and prevents users from changing them. If you enable this setting, Google Chrome will always check on startup whether it is the default browser and automatically register itself if possible. If this setting is disabled, Google Chrome will never check if it is the default browser and will disable user controls for setting this option. If this setting is not set, Google Chrome will allow the user to control whether it is the default browser and whether user notifications should be shown when it isn't.
    Example value:
    0x00000001 (Windows), true (Linux), <true /> (Mac)
  • I dont see Google in Policies :( do i have to create it manually??
    • Yes, you can just create the missing keys/values manually. Normally they would have been created by the GPO if you had imported the ADM file. But if you're just wanting to go the registry route, you would manually create them.
      • I tried to do that, it doesn't work! As per my understanding i created POLICIES>GOOGLE>CHROME>DefaultBrowserSettingEnabled>Boolean (REG_DWORD) VALUE=0x00000001

Did you create the key under HKLM or HKCU?

Answered 02/24/2014 by: dunnpy
Red Belt

  • Doesnt work in HKLM and HKCU, tried reboot and re-login too... please help

Chose another setting to apply and test whether that applys correctly.

Answered 02/24/2014 by: dunnpy
Red Belt


Thanks to Dunnpy and BHC-Austin:


Answered 02/26/2014 by: shreeitninja
Blue Belt

This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ