Scripting Question

How do I create a managed install for Java 8 Update 60?

09/03/2015 7825 views
I've read through this: http://www.itninja.com/blog/view/mastering-managed-installs

Also tried the steps here: https://support.software.dell.com/k1000-systems-management-appliance/kb/149248 (while changing the file/script to match 8u60)

I've used the command in Managed Install:  msiexec /i jre1.8.0_60.msi AUTO_UPDATE=0 EULA=0 NOSTARTMENU=1 SPONSORS=0 WEB_ANALYTICS=0 WEB_JAVA=1 WEB_JAVA_SECURITY_LEVEL=H /qb

and the script: jre-8u60-windows-i586.exe /s INSTALL_SILENT=1 AUTO_UPDATE=0 REBOOT=0 /L C:\Windows\Logs\JAVA8-install.log

When I use the msiexec command above for a managed installation, I get the following error: Unable to open file C:\ProgramData\Oracle\Java\java.settings.cfg. Check that the configuration file exists and that the path to the file is correct.

When I use the script, Java does not install.

Can anyone help me with this?

Answer Summary:
1 Comment   [ + ] Show comment


  • By chance, have you experimented with running the distro when someone is logged in? We have found some distros cannot be installed unless someone is logged in.

Answer Chosen by the Author

ensure that an empty file with that name is in the location specified, and it will work. AFAIK it's a bug in the current release..
Answered 09/03/2015 by: Pressanykey
Red Belt

  • Thanks! I actually created an online kscript that copies an empty java.settings.cfg file to the specified directory for task 1, and then task 2 installs Java silently.

All Answers

You cannot push out Java 8 using the MSI installer anymore unless you have enterprise support from Oracle. You have to use the EXE with the right parameters in order to install properly. Simply jre-8u60-windows-i586.exe INSTALL_SILENT=1 AUTO_UPDATE=0 WEB_ANALYTICS=0 REBOOT=0, should suffice.

Unless you're accessing the EXE via dependency, be aware of the bug I found if you're planning to push it out via software package using scripts, as mentioned in my bug report:


Also, since you're pushing a 32-bit version of Java, it may not install on 64-bit computers correctly if your script is running as SYSTEM. More info on that in one of my comments from that link above.
Answered 09/09/2015 by: axie
White Belt

  • Thank you, and I appreciate your help.

    I actually got the MSI to install by setting up a task within the kscript to add the file java.settings.cfg in the C:\ProgramData\Oracle\Java directory before running jre1.8.0_60.msi AUTO_UPDATE=0 EULA=0 NOSTARTMENU=1 SPONSORS=0 WEB_ANALYTICS=0 WEB_JAVA=1 WEB_JAVA_SECURITY_LEVEL=H /qb

    When I run the script as local system, it's hit an miss as to if it works or not. For my batch files to remove previous versions of Java and to create a java.settings.cfg file, I get the message that "The system cannot find the file specified" on remote computers only. On computers in my office, Java installs without a hitch.

    I'm going to try it as a domain admin account to see if there are any different results. I'm also going to try the method that you suggest.
    • Ok, I just tested this with an empty java.settings.cfg and the MSI worked for me too. I'm gonna try it out on a fresh VM and see if that really did the trick. Thanks.
      • Did the msi install on your VM?

        One issue that I'm having now is that the script works when pushed to some remote sites, but not others. The same is true when I try the script using the .exe in your other post.
      • I honestly been deploying using simply jre1.8.0_60.msi /q /norestart. I didn't even bother creating the java.settings.cfg file in the ProgramData area and it still works. Can't figure out why I can't reproduce the error anymore.
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ