/build/static/layout/Breadcrumb_cap_w.png

Scripting Question


I am having some issue successfuly passing a application through SCCM, I have posted the script below.

06/13/2016 1431 views

Good morning, I am looking for some help with an application that I need to place through SCCM, but I cannot seem to have the application pass successfully. I have posted the upgrade script below. Any help is welcomed.


Thank you




::    ############# Uninstall Emdeon Verify-9.0.0.74 ############  

"%~dp0Emdeon Verify-9.0.0.74-R2\Verify_9.0.0.74.exe" -s -a remove_silent

net localgroup "TWUser" bcbsmamd\GG-TRANSFORM-USER /delete
net localgroup "TWUser" bcbsmamd\GG-TRANSFORM-ADMIN /delete


net localgroup "TWadmin" bcbsmamd\GG-TRANSFORM-ADMIN /delete
net localgroup "TWadmin" "bcbsmamd\DAKOTA SUPPORT" /delete

net localgroup twadmin /DELETE
net localgroup twuser /DELETE

Reg delete "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\eventlog\Transform" /f
RMDIR /S /Q "C:\ProgramData\Emdeon"
RMDIR /S /Q "C:\Program Files\Transform"
RMDIR /S /Q "C:\Program Files (x86)\Common Files\Emdeon"
RMDIR /S /Q "C:\Users\LocalService\Application Data\Emdeon"
RMDIR /S /Q "C:\Transform"

msiexec /x {00B4520C-48AA-66DC-5E1D-26A041181F5F} /qn /l*v "%windir%\support\logs\sqlany10_client_UNINSTALL.LOG"


@echo off
::       ###### Run silent Search installer with response .ini file for Emdeon Verify 9.3.1.3 ######
"%~dp0Verify_9.3.1.3.exe" -s -a -i "%~dp0VerifyInstaller.ini"


::       ###### Add AD groups to local groups. ######
net localgroup "TWUser" bcbsmamd\GG-TRANSFORM-USER /add
net localgroup "TWUser" bcbsmamd\GG-TRANSFORM-ADMIN /add


net localgroup "TWadmin" bcbsmamd\GG-TRANSFORM-ADMIN /add
net localgroup "TWadmin" "bcbsmamd\DAKOTA SUPPORT" /add


Del /f /q "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Telework\Verify\Verify Uninstall.lnk"
RMDIR /S /Q "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Transform"


MSIEXEC /i "%~dp0SQL Anywhere\sqlany16_client.msi" /qb ALLUSERS=1 /l*v "%windir%\support\logs\SQL Anywhere\sqlany16_client_INSTALL.LOG"

"%~dp0SetACL.exe" -on "HKLM\SOFTWARE\Wow6432Node\dakota imaging" -ot reg -actn ace -ace "n:twadmin;p:full"

"%~dp0SetACL.exe" -on "HKLM\SOFTWARE\Wow6432Node\dakota imaging" -ot reg -actn ace -ace "n:twuser;p:read"

1 Comment   [ + ] Show comment

Comments

  • any reason why you are removing then adding the same users from the local groups??
    If you try and add a domain user, I think you will need to run it with an AD account as it will try to resolve the AD group or user. The SCCM system acc wont be able to do that.

All Answers

0

- By "pass", do you mean "run" or perhaps "execute"? Assuming so:

- Is the script set to run in user or system context?

- Which of the 24 steps is failing?

- Have you tested the script using PSExec with the '-s' argument?

Answered 06/13/2016 by: anonymous_9363
Red Belt

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ