/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


K2000 Extender has postinstallation task files missing?

08/01/2012 3905 views

Visited a remote site yesterday to refresh the systems with a scripted install that works great at the main site. Found that a couple softwares weren't installed. Looked closer and saw that the Extender's peinst directory was messed up. It had the script dependency directories, but for the two missing software I found  that not all the files were there.

In the case of my adobe reader installation script, it had the "contents" folder, but was missing a couple files. For my Office installation, it had the zipped depedency, but the "contents" folder was missing, like it failed to unzip it.

I checked a second extender ( that had the same scripted install ), and found the same exact issue.

I tried syncing the extenders, which they did without error, letting me know sync was complete and there were 0 bytes needed to transfer.

Has anybody seen this issue? How can I correct the peinst directory on the extender? 

 

UPDATE:
I was able to workaround this error by duplicating the afflicted tasks, and swapping in these duplicate tasks to a new SI. I found that these new tasks didn't have the issue. 

Answer Summary:
0 Comments   [ + ] Show comments

Comments



Community Chosen Answer

2

Hi

I created a ticket at KACE for this issue some time ago, it is a know bug, if you upload a piece of software (bigger zip file) and then right after sync with a remote site then it could get messed up, you should upload the file, then wait 10 minutes before you sync.

I had the problem with Office 2010 missing ALOT of files.

It should be fixxed in the next version, but the work around right now should be to wait 10 minutes or so before you sync it.

I hope that helps
- René

Answered 08/03/2012 by: rmeyer
Second Degree Blue Belt

  • Thanks for the hand's on info

All Answers

1

I'm assuming they're all the same version? 

Try reuploading the installer.

Answered 08/01/2012 by: dugullett
Red Belt

  • The postinstallation task is fine on the K2000.

    Yup, same version.
    • I saw another post where cserrins suggested reuploading the installer to the K2. This fixed it. I'm working on finding the link. I'm curious if this will fix your issue. The only problem is how will you know in the future if it happens again?
  • dugullett is this the one you were thinking of?
    http://www.itninja.com/question/k2-extender-sync-stuck-in-building-file-list
    or
    http://www.itninja.com/question/k2000-rsa-google-earth-itune-bonjour-not-installing
  • I created a SI that was missing the two damaged postinstallation tasks. I then synced that over and removed the existing SIs.

    Now I am syncing over the original SIs and will report if that fixes the broken tasks.
  • Postinstallation tasks transferring over and already I can see that the reader script is in the same state.
  • I would do what corey suggested to the other persom then

    cserrins | 04/20/2012 |
    Flag


    I would call in to support to get a tether, this is something we can fix on the backend.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ