/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


MSVCR71.dll

05/09/2012 4756 views

Sorry if this is not the correct section. I'm looking for an old Microsoft C++ Runtime Library software package that contained MSVCR71.dll and associated files to package up and deploy out to 'C:\Windows\System32'. I'd rather not download seperate files from somewhere like http://www.dll-files.com/ but use a package from a more trusted source. I have looked at .NET Framework SDK Version 1.1 and it contains the files but it is a large install at over 100MB and I'd rather have something that is approximately less than 5-10MB. Something similar to 'Microsoft Visual C++ 2008 Redistributable Package (x86)' which is less than 5MB.

Answer Summary:
The msvcr71.dll would also be present in hardware device drivers and .NET Framework SDK version 1.1.
0 Comments   [ + ] Show comments

Comments



Community Chosen Answer

3

I think you might be looking for the merge module (msm) file for these files. Do you have an IDE like Wise or InstallShield available? You should be able to find the file in there? Specifically the filename of the msm that contains this dll on my system is VC_User_CTR71_RTL_X86_---.msm

Answered 05/09/2012 by: pjgeutjens
Red Belt

All Answers

1

The msvcr71.dll may also be present in your video card or any other hardware device drivers.

You can do a quick check by updating hardware drivers one by one and see if the issue gets resolved at any sequence.

Answered 05/09/2012 by: adilrathore
4th Degree Black Belt

1

You can also use the sfc /scannow command that is used to replace missing or corrupt dlls.

Answered 05/09/2012 by: adilrathore
4th Degree Black Belt

1

We use Windows 7 and that file is not there by default (as far as I'm aware), so I don't think it's a matter of scanning to replace files. I am looking for it to deploy out to classroom computers.

Answered 05/09/2012 by: alphabeta
Black Belt

1

Actually, I'm pretty sure the standard installer for .NET Framework 1.1 (not the SDK) also contains this file. At 23mb that seems manageable to me.

However (not sure about this) it might be that the presence of a newer version of the runtime would prevent the installation of an older version, you'll need to test that

Answered 05/09/2012 by: pjgeutjens
Red Belt

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ