/build/static/layout/Breadcrumb_cap_w.png
08/01/2019 103 views

Hello all,


I've been having some issues creating MAC distributions in our K1000 for installs that require you to run the install through the .app>contents folder.  For example, I'm currently trying to get a working Sophos distribution.  According to Sophos, the below can be used:


sudo ./Sophos\ Installer.app/Contents/MacOs/Sophos\ Installer --products antivirus intercept --quiet


I currently have a zip which contains the .app and the necessary .plist file.  The distribution is set to run the above command under 'Override default installation' with the command being in the full command line.  I uploaded the zip, run the distribution, and KACE does copy, and unzip, the installer and plist to /Library/Preferences/Application Support/Quest/KACE/Downloads/#### but it doesn't run anything and just completes right away. If I run it manually from that folder, it installs so it's definitely something with triggering the install.  Does anyone have any recommendations as to what to put in the distribution to have it run the Installer within the contents?


I tried putting both in a .dmg and that did not work either.  I also tried specifying the full path: sudo ./Library/Preferences/Application\ Support/Quest/KACE/Downloads/####/Sophos\ Installer.app/Contents/MacOs/Sophos\ Installer --products antivirus intercept --quiet


Thanks in advance for any help.



0 Comments   [ + ] Show comments

Comments


There are no answers at this time