/build/static/layout/Breadcrumb_cap_w.png

ITNinja Question


Upgrading VMWare Tools on Kace 8.0.318 (VA on ESXi 6.5)

12/13/2017 3791 views
Good afternoon.
Today I updated Kace to version 8.0.318, we have a VA hosted on an ESXi infrastructure. When I try to update VMTools I obtain this error:

The required VMware Tools ISO image does not exist or is inaccessible.
vix error code = 21001
Unable to install VMware Tools. An error occurred while trying to access image file "/usr/lib/vmware/isoimages/freebsd.iso" needed to install VMware Tools: 2 (No such file or directory). Please refer the product documentation or KB article 2129825 for details about how to get VMware Tools package for this guest operating system.
I found a VMWare documentation on http://partnerweb.vmware.com/GOSIG/FreeBSD_11x.html#Tools, but I can't try this because the solution need a root access to the VA. Can someone help me and give me an idea about the possible solution of the problem?

Thanks in advance.
Giovanni.
Answer Summary:
4 Comments   [ + ] Show comments

Comments

  • You might want to check this KB:
    "VMWARE tools cannot be updated in the K1000 and K2000 appliances in ESXi 6.5"
    https://support.quest.com/kb/217335/
  • Hello Channeler, I have already read the KB, but for FreeBSD 11 VMware suggest the solution available on http://partnerweb.vmware.com/GOSIG/FreeBSD_11x.html#Tools. The problem is, as I said in my previous comment, there is no root access to the Kace server, then I ask if exist another method to install VMware tools.

    Thanks.
    • you don't need root access!
      You need to mount the latest vmwaretools.iso for freebsd to the virtual machine (Be sure that it is set to connected) and then simply use the webui (Settings |Appliance Upgrade) to install/upgrade them.

      The issue you are decribing is that you did not connect the vmware tools iso to the appliance.
      • in a future release KACE will also move to the openvm-tools so you don't need to do anything here anymore, since the appliance updates the tools internally with each upgrade.
      • Hi Nico and sorry for the late reply. I can't find vmwaretools.iso for FreeBSD 11 on my.vmware.com. Can You help me to find the correct file?
  • Release Notes VMWare: FreeBSD support: freebsd.iso is not available for VMware Tools 10.2.0 and later as it has been discontinued in favor of open-vm-tools.
  • So there are VMware Tools 10.1.10 and 10.1.15 you can download from https://my.vmware.com/group/vmware/details?downloadGroup=VMTOOLS10110&productId=614 and https://my.vmware.com/group/vmware/details?downloadGroup=VMTOOLS10115&productId=614 you'll want the VMware Tools packages for FreeBSD, Solaris and OS X download available as either a .zip or a tar.gz you then upload the freebsd.iso file to a datastore and mount that to the KBOX virtual CD Drive to upgrade the tools.

    The bad news is in 10.2.0 VMware have dropped support for FreeBSD completely, requiring the use of open-vm-tools instead as stated in the release notes here: https://docs.vmware.com/en/VMware-Tools/10.2/rn/vmware-tools-1020-release-notes.html#compatibility

    I appreciate this is VMware's doing of dropping support, but KACE really shouldn't publish an article https://support.quest.com/kace-systems-deployment-appliance/kb/217335 pointing fingers at VMware and appearing to bury their heads in the sand as "nothing to do with them". Enterprises want to use Enterprise hypervisors, and VMware is popular in this field, they also chose KACE KBOX and. It's unfortunate VMware have decided to drop FreeBSD support, but they have, so we look to Quest KACE our vendor to adapt for its customers to changes in the industry, (its why the web client has HTML5 version now which hopefully by 2020 will be the main version with all features, didn't just point to Adobe and do nothing), otherwise customers may adapt themselves, away from Quest KACE KBOX, there's already pressure here to switch to SCCM.

    Nico_K, can you confirm that newer versions of KACE virtual appliances will handle installing and updating of the Open-vm-tools? We need an official communication from Quest KACE on this as I'm sure you can appreciate.

    We need to know that a future version of the KBOX appliances will handle this to ensure communication with VMware is maintained, or KACE will migrate to a different Linux OS that VMware do still support with VMtools.

Answer Chosen by the Author

0
According to the kb linked to earlier, you just need to download "VMware Tools packages for FreeBSD, Solaris and OS X" and use the one called freebsd.iso. In the kb it says to also download the "Windows and Linux" iso as well. But I'm not sure what that one is needed for. The KB is definitely lacking in details. But once you've downloaded the, upload all of the iso's (windows.iso, linux.iso, darwin.iso, freebsd.iso, solaris.iso) via the esxi webclient (Host | Storage | Storage Browser). And then mount the proper one on the VM in question.

Haven't tested it, but it looks straight forward.

Two more vmware articles that might help you:
VMware vSphere ESXI 6.5 Release Notes (specifically talks about not all .iso's being included)
VMware Tools 10.1.5 Release Notes
Answered 01/03/2018 by: five.
Second Degree Green Belt

All Answers

0

"With SMA 8.1 and a future SDA version the open vm tools are uses so this will no more needed."

https://support.quest.com/kb/111198/how-to-install-vmware-tools-on-the-k1000

Answered 12/05/2018 by: pc2550
White Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

View more:

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ