/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


Windows 7 Image not auto-logging in.

07/28/2017 834 views

Hello Everyone,

Our company has recently switched from Altiris 6.9 to K2000 4.1.182. I'm trying to re-build an image for our Windows 7 Laptops and trying to get them to autologon during the oobeSystem phase of setup, but it's not working. When the computer reboots I get an error message saying "The username or password is incorrect", but the correct username is displayed, and entering the password proceeds as expected.

The weird thing is this is the same unattend.xml that was working correctly with Altiris, and I've double checked against the one I'm using with our Windows 10 image (which autologons fine) and everything looks the same. WSIM is validating the XML correctly as well.

After a little digging (deploying the image, and then using notepad to remove the part where kace injects the engine back into setupcomplete.xml) I was able to logon once, and check the registry. It looks like the DefaultPassword value is not being set.

I'm going to go out on a limb and assume that this is caused by some sort of windows update in the image, but I don't know what one.

Is there anyone who is more Windows-Setup savvy than I who can recommend a workaround for this? Anywhere I can think to manually set the registry keys works after first logon. Is there a way to set it as a mid-level task and hope that it's not being set, and hopefully not being set to blank?

I look forward to any suggestions.

1 Comment   [ + ] Show comment

Comments

  • Hello Chris,

    I have a couple of questions for clarity. Are you using a scripted install or are you working with an image of a sysprep-ed Windows 7 install? Could you post your answer file? (Properly redacted of course) The unattend files are different depending on which way you are deploying Windows 7.

    If you are using an image, you can use the KACE sysprep creator to help craft your unattend.xml. On the other hand, scripted installs have a wizard to help with the answer file. We have had success with both methods.

    Thanks;

    Chas Baker
    • Hi Chas, It's a image of a sysprepped windows 7 Installation. The weird thing is it worked before. Here's my redacted Unattend.xml. I'm not sure if there is a better way to attach it.

      <?xml version="1.0" encoding="utf-8"?>
      <unattend xmlns="urn:schemas-microsoft-com:unattend">
      <settings pass="specialize">
      <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <Identification>
      <Credentials>
      <Domain>COMPANY.NET</Domain>
      <Password>PLAINTEXTPASSWORD</Password>
      <Username>KACEAdmin</Username>
      </Credentials>
      <JoinDomain>COMPANY.NET</JoinDomain>
      </Identification>
      </component>
      <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <RegisteredOrganization>COMPANY</RegisteredOrganization>
      <RegisteredOwner>COMPANY</RegisteredOwner>
      <ShowWindowsLive>false</ShowWindowsLive>
      <ComputerName>*</ComputerName>
      <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
      <CopyProfile>true</CopyProfile>
      <TimeZone>Eastern Standard Time</TimeZone>
      <ProductKey>PRODUCTKEY</ProductKey>
      </component>
      </settings>
      <settings pass="oobeSystem">
      <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <AutoLogon>
      <Password>
      <Value>PLAINTEXTPASSWORD</Value>
      <PlainText>true</PlainText>
      </Password>
      <Domain>COMPANY.NET</Domain>
      <Enabled>true</Enabled>
      <LogonCount>6</LogonCount>
      <Username>KACEAdmin</Username>
      </AutoLogon>
      <OOBE>
      <HideEULAPage>true</HideEULAPage>
      <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
      <NetworkLocation>Work</NetworkLocation>
      <ProtectYourPC>3</ProtectYourPC>
      </OOBE>
      <UserAccounts>
      <AdministratorPassword>
      <Value>ENCRYPTEDPASSWORD</Value>
      <PlainText>false</PlainText>
      </AdministratorPassword>
      <LocalAccounts>
      <LocalAccount wcm:action="add">
      <DisplayName>TempAccount</DisplayName>
      <Name>TempAccount</Name>
      <Group>Administrators</Group>
      <Description>Temporary Account</Description>
      </LocalAccount>
      </LocalAccounts>
      </UserAccounts>
      <TimeZone>Eastern Standard Time</TimeZone>
      <RegisteredOrganization>COMPANY</RegisteredOrganization>
      <RegisteredOwner>COMPANY</RegisteredOwner>

      </component>
      <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <InputLocale>0409:00000409</InputLocale>
      <SystemLocale>en-us</SystemLocale>
      <UILanguage>en-us</UILanguage>
      <UILanguageFallback>en-us</UILanguageFallback>
      <UserLocale>en-us</UserLocale>
      </component>
      </settings>
      <cpi:offlineImage cpi:source="wim:c:/users/chris/desktop/sources/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
      </unattend>
      • Hi again Chris;

        Looks like you are using a domain account for your autologon. We use a local account in the administrators group for the auto-logons post sysprep or post install. The network being up for authentication against AD did not seem to be reliable enough at that point in deployment. Would you consider using a local account for the OOBE to run? It would mean some changes in your unattend.xml.

        Chas

Be the first to answer this question

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ