/build/static/layout/Breadcrumb_cap_w.png

App-V with Java/JRE/JDK

It is very critical to understand how to handle installation of Java related applications in App-V environment.
While some are of the view that the application should be installed along with Java in the same bubble while some say that the Java version installed on the base machine can be used.

Here is how you can do both of these in a proper way:

1) Java installed locally on the machine: If Java is locally installed on the machine and you capture the App-V application, then you will see a hard coded entry in the registry. This basically points the App-V application to look for Java in this local machine location. If you upgrade your Java version from say 1.6.21 to 1.6.24, then you do not need to worry, however, if you do a major upgrade from 1.6.21 to 1.7.xx then you need to upgrade your App-V Application as well. You need to maintain the software library for all these applications and then upgrade them as part of Java Upgrade in the organization.

2) Java is installed as local copy inside App-V bubble: Java can also be installed as a local copy with your App-V application. There can be various reasons for doing this:
 a) Application is compatible only with a certain version of Java
 b) Application uses a higher version which is not locally installed.
 c) If Software manager do not want to upgrade the application every time Java gets updated.

In these cases a private copy of Java can be captured with App-V. However, there is a procedure for achieving this.
These steps will be helpful in doing this:

http://packagingguide.blogspot.com.au/2011/11/app-v-for-java-runtime-environment.html


Comments

  • So, App-V will look into it's bubble for Java first and if it finds it then it will use it. If it looks in it's bubble first and doesn't find it then it will look outside the bubble to the local and use the Java found there. Nice Blog! - seando40 8 years ago
  • Thanks :) - piyushnasa 8 years ago
  • Hi Piyushnasa,
    Have you any idea for handling a AppV package having JAVA components as well as having dependency of ORCL_JRE6UPDATE27_00, As it's showing me installation error in SCCM 2012 as well as while publishing the same Manually through Powershell. - dasham 8 years ago
  • I have packaged App-V application with Java. What is the error that you are getting?
    You have to first install Java and then install your application and capture this together in one bubble. Check if there is any hardcoding in the environment variable/registries. you might have to change that.
    Try Local Interaction as true to test it out as well. - piyushnasa 8 years ago
  • Hi Piyushnasa,

    Thanks for your reply, I resolved the above issue by sequencing the application manually and packaged bot AppV and JRE6 in same bubble through AppV 5.0, but my question is, is this recomendend that we should do this in AppV 5.0 as this is restricted in AppV 4.6 to package JAVA and any application in same bubble as per below site.

    http://support.microsoft.com/kb/932137 - dasham 8 years ago
This post is locked
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ