Software Deployment Question

Firefox 14 on Windows XP - install addons automatically - need to stop this

08/23/2012 22678 views

Hi all,

I have packaged Firefox 14 for both our Windows XP environment and our Windows 7 environment. We are currently transitioning from XP to Windows 7 therefore require it on both builds.

On Windows 7 once the package is installed and the user runs Firefox for the first time it runs without any prompts and without a problem. I created my msi package from a snapshot and set my firefox properties using the Mozilla.cfg, override.ini and local-settings.js files after following the recommended guidelines for packaging Firefox.

However, on Windows XP, on first run Firefox checks to see what Addons are available and want to interact with Firefox. Therefore the user is presented with a window where they can select/deselect whatever Addons they feel like instaling. This is an issue, as, one of the Addons is Symantec Intrusion Prevention which we really want turned on.

A user can tick the relevant tick box and it will install for that user but if a user chooses not to install the Addon then it's not installed and the user could be left vulnerable.

This is also a per-user setting and not a per-machine setting so will need to be done for each user.

I have performed a capture of ticking each of the boxes on first run and managed to capture what changes were made. I noticed that a number of files are created/modified in the users Appdata folder - AppData\Mozilla\Firefox\Profiles\%username%.

So I was thinking of adding these files to my msi and using Active Setup to install them for each user.

However, I don't know how I would do it so that the folder would change for each user? I was thinking of using the SetProperty Custom Action and the Set Directory Custom Action and using them to take in the %username% variable and populate the directory that way. But it's been a long time since I did something like this and I'm very rusty.

Anyone got any recommendations for a solution to my problem?



Answer Summary:
pref("extensions.autoDisableScopes", 0); pref("extensions.enabledScopes", 15);
0 Comments   [ + ] Show comments


All Answers


I'm sure someone will have a better answer, but this looks interesting: http://mike.kaply.com/2010/06/18/customizing-the-firefox-installer-on-windows/

Answered 08/23/2012 by: jknox
Red Belt

  • Hi thanks for that. I read through it and tried changed the contents of the application.ini file. I changed the value on the following 2 lines to 0. EnableProfileMigrator=0
    However, this hasn't made a difference on Windows XP. I still get asked to install the Addons.
    • I don't know if it helps with your issue, but I didn't realize that link was from 2010, here's one from this year: http://mike.kaply.com/2012/02/14/customizing-the-firefox-installer-on-windows-2012/

      This might help too: http://www.itninja.com/blog/view/deployment-of-mozilla-firefox-12

All settings files under ...\defaults\pref\ and ...\defaults\Profile\ will be copied to the users profile on first run.

Type about.config in the adress bar and see if you can find your setting there.

Search for something like extensions.enableAddons, after you've configured it the way you want.

Then add the prefs.js file (from your installation) to your installation under .\core\defaults\Profile\prefs.js

Answered 08/24/2012 by: andemats
2nd Degree Black Belt


Hi guys, The information in this website answered my question. I added these 2 lines to my mozilla.cfg file -

pref("extensions.autoDisableScopes", 0);
pref("extensions.enabledScopes", 15);
Thanks for your advice! I've managed to get it finished.
Answered 08/24/2012 by: mark_holland21
Fourth Degree Green Belt

  • Sorry, here's the website - http://mike.kaply.com/2012/02/21/understanding-add-on-scopes/
  • mark this as answered and put in solution for the ninja points
  • I had also had to deploy Firefox 14 so it never remembered History and always asked users where to download to. Bit of a nightmare working out the switched but adding the following to the Mozilla.cfg file worked for me:

    pref("browser.privatebrowsing.autostart", true);
    pref("browser.download.useDownloadDir", false);
Answered 08/23/2012 by: SMal.tmcc
Red Belt


You can also have a look here:


This will work for 14 as well.

Answered 08/24/2012 by: piyushnasa
Red Belt

This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ