/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


installing .net framework 2.0 sp1

01/21/2009 5896 views
hi all,

trying to get some clarification on deploying ms .net framework 2.0 sp1. i've looked at the package knowledgebase about .net framework 2.0 but the details aren't exact.

i've downloaded netfx20sp1_x86.exe and extracted it. i have a setup.exe, not an install.exe. i created an sms package with the command line: setup.exe /i /q. this seems to run the install silently, but on some test machines it rebooted the system without notification or question. i can't allow this.

so is there either a switch for setup.exe to prevent a reboot, or should i be using an msi with a /noreboot? in the extracted set i've found wcu\dotnetframework\dotnetfx20\netfx_20a_x86.msi, is that the one to use?

thanks in advance.

daniel.
0 Comments   [ + ] Show comments

Comments


Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

All Answers

0
Try running the MSI with REBOOT=ReallySuppress

msiexec /i whatever.msi REBOOT=ReallySuppress /qb-
Answered 01/21/2009 by: turbokitty
6th Degree Black Belt

0
Hi,

Extracting netfx20sp1_x86.exe is also not required. If you can deploy this .exe directly through sms then use the following parameters.

netfx20sp1_x86.exe /passive /norestart

Regards
Ramesh
Answered 01/22/2009 by: ramesh111k
Purple Belt

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ