/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


KACE K1000 how do you check why a managed install didn't install / failed ?

04/30/2018 2597 views
I recently got into using Managed Installs with KACE where I use them to call a batch file to install a program. I have a couple active ones right now, one for Flash Player 29 (batch file which runs the flash player uninstaller and then the msi) and one for Java 8u172 (batch file which runs a command to uninstall previous version of java and then installs the new one via .msi). I've got them set to push to about 20 machines in our environment and for some reason these push successfully to 5-10 machines and for the rest return a "Not Installed (3 of 3 attempts)" or just plain "Not Installed". Where can I go to check to see what is happening? I looked at the Klogs for a machine but it didn't appear to show anything for the managed installs, and just had regular missing patch info. That said, I pushed the patches on Friday/Sat and it is now Monday so am I just too late at checking the logs, since the logs only have info from today ? Any suggestions or tips for managed installs?
4 Comments   [ + ] Show comments

Comments

  • Have you looked at the device's event logs? I've found answers in there at times for failed installations
  • If you save the managed install again it will reset the failed attempts and try again. At that point force an inventory on a machine and it should try the managed install. Check the event logs on the machine. If you aren't sure where in the process your task is failing, then you can always build logging into your batch file to record steps along the way.
  • I found these articles very helpful:
    1.https://support.quest.com/kb/114922/troubleshooting-managed-installs

    2. https://support.quest.com/kace-systems-management-appliance/kb/133819/reading-the-kagent-log-managed-install
  • Just tried again (saved the install so it tried again) and same thing - installed on a few machines but the majority of them are "not installed (attempt A of B) or just "not installed"). Checked event viewer, one machine had no errors or even KACE events, but another had:
    "The Quest KACE One Agent service terminated with the following service-specific error:
    The system cannot find the file specified"

    Is there a way to see what file it's looking for? Since it IS installing on some machines I'm thinking its not an issue with the package itself. Does KACE download the managed installs somewhere? For example SCCM downloads all deployed packages to a specific directory on the endusers machine. It would be helpful to check to see if the install is actually making it to peoples machines. If not that would explain the file not found thing. Maybe there is something else going unrelated to KACE: machines being turned off or going to sleep or something preventing the K1000 from communicating with them.
    • Managed install files are located in "C:\ProgramData\Quest\KACE\downloads". To get more details out of the KACE logs set logging to the most verbose level by adding/changing this line in amp.conf:
      debug=all
      I find the "KAgent.log" in "C:\ProgramData\Quest\KACE\user" to be helpful

All Answers

0

Hi Winterelegy,

You may want to check to make sure that those computers that did not receive the patch are able to wake on LAN.



Answered 05/17/2018 by: cbernard
White Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ