/build/static/layout/Breadcrumb_cap_w.png

macOS Catalina and scripts that asks for authorization

I until Mojave I was used to install some kind of software using Kace Online Shell scripts with commands like the following:

sudo /usr/sbin/installer -pkg MyApplication-x86_64.pkg -target /

starting from Catalina, the same script with the same application failed. If I run the same script directly from the bash I get this window

and I guess this is the reason why the script fails. It does not have enough permissions.

Is there a way to get rid of this? I know that I would need a MDM, but I need to push a critical software before people upgrade to Big Sur.

Thanks




0 Comments   [ + ] Show comments

Answers (1)

Posted by: chucksteel 2 months ago
Red Belt
0

You need to install a privacy profile to give scripts the correct access. Here's a utility that will generate them for you:

https://github.com/jamf/PPPC-Utility 

Also, the KACE client already runs in the root context, so there is no need to prepend commands in scripts with sudo.


Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

View more:

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ