/build/static/layout/Breadcrumb_cap_w.png
10/16/2019 452 views

I have a problem with my Win10 1903 Image deployment. The deployment of the Image is fine and all no errors what so ever. But after rebooting the Workstation i get following error.


"bootmgfw.efi is not recognized as internal or external command, operable programm or script file".


Preinstallation Tasks


select disk 0

clean

convert gpt noerr

create partition efi size=200

assign letter=s

format quick fs=FAT32

create partition msr size=128

select disk 0

create partition primary size=95000

select Partition 3

assign letter=c

format fs=NTFS label="Windows" quick


select disk 0

create partition primary

select Partition 4

assign letter=d

format fs=NTFS label="Daten" quick

exit


Mid Level Tasks


bcdedit /set {bootmgr} device partition=s:

bcdedit /set {memdiag} device partition=s:

bcdedit /set {default} device partition=c:

bcdedit /set {default} osdevice partition=c:

Bcdedit /set {FWbootmgr} displayorder {Bootmgr} /addfirst

bootsect /nt60 s:



We run the same Tasks for WIN10_1809 Images without any problems at all. 

4 Comments   [ + ] Show comments

Comments

  • What partitions were captured for this Image?

    Make sure you are booting from a UEFI boot source. (Look at the KBE footer, it should say Boot Mode: UEFI, before you start imaging).
  • C and D but we have an Image with C D and S aswell. no success.

    With our WIN10 1809 all is working proberly same settings and all.
  • Can you confirm there are 3 partitions being created on the disk? I see you have a "Select partition 3" in there
  • ye i have S (efi) C and D the partitions are created but he doesnt know where to boot from

All Answers

0

only difference from mine is I do not have the last line in my mid task

2Q==

Answered 10/17/2019 by: SMal.tmcc
Red Belt

0

You could try this as your mid level task:

bcdboot c:\windows /s s: /f UEFI
bcdedit /store S:\efi\microsoft\boot\bcd /set {bootmgr} device partition=s:
bcdedit /store S:\efi\microsoft\boot\bcd /set {memdiag} device partition=s:
bcdedit /store S:\efi\microsoft\boot\bcd /set {default} device partition=c:
bcdedit /store S:\efi\microsoft\boot\bcd /set {default} osdevice partition=c:
Bcdedit /store S:\efi\microsoft\boot\bcd /set {FWbootmgr} displayorder {Bootmgr} /addfirst
bootsect /nt60 s:

Answered 10/25/2019 by: gerald_mack
Orange Belt