/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


Unable to boot VMWare into KBE ISO

06/03/2020 149 views

We recently created a brand new SDA which is running on version 7.2.

We were previously using version 4.x, where we would create a KBE with the KBE Manipulator. This booted physical machines and VMs without issue.

Since we upgraded, I followed this guide https://www.itninja.com/blog/view/sda-imaging-best-practices-sda-6-x using Kace Media Manager to create the KBE.

This KBE works fine on physical hardware.. It loads the drivers, properly pings the appliance, and places us at the Imaging menu. (we are burning the ISO to a bootable USB as our PXE not yet configured), but when booting on a VM, it prompts "Press any key to boot from CD or DVD", accepts no input, and then returns to firmware, where the keyboard works fine.


Lz7CafnWClMFAAAAAElFTkSuQmCC


I took whatever drivers I could find off the VMWare Tools installation media, which seemed to only be 'pvscsi' which didn't help anything.

Has anyone experienced this before? Why will a physical machine boot the ISO properly, but a VM won't even begin the boot process?

I thought https://support.quest.com/kace-systems-deployment-appliance/kb/133519/unable-to-boot-to-kbe-iso-from-a-uefi-virtual-machine might be the cause, but that seems to only affect version 6.x and lower.

The KBE was built on Windows 10 v1809 (LTSC) using the Windows 10 v1809 ADK with WinPE Addon package.

Thanks!

0 Comments   [ + ] Show comments

Comments


All Answers

0

Version 7.2 comes with it's own Media manager.

See (7.2 KACE SDA Aministrator's Guide):
https://support.quest.com/download/downloads?id=6103337

(make sure you are logged in to download the PDF file).

Page 44, "About the Media Manager", contains information about all the settings available in the 7.2 Media Manager.
Page 46, Advanced Options, talks about theĀ UEFI ISO option, make sure that option is enabled, and build a new KBE with that one checked.

This should let you build a KBE capable of producing a UEFI compatible ISOs,
NOTE: doing this could prevent this KBE from PXE Booting, probably that is why it comes disabled by default.

Also, make sure your VM has at least 4GB of RAM, and 2vCPUs.
I recommend using the E1000 NIC Adapter type.



Answered 06/04/2020 by: Channeler
Red Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ